1138: C语言合法标识符

1138: C语言合法标识符

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 2902   Solved: 1251

Submit Status Web Board

Description

输入一个字符串,判断其是否是C的合法标识符。

Input

输入一个长度不超过50的字符串。

Output

如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。

Sample Input

8fixafghgjhjhjyuyuyyuyuyu

Sample Output

no

HINT

Source

#include<stdio.h>
#include<string.h>
#include<ctype.h>
int main()
{
    char ch[50];
    int i,l=0;
    gets(ch);
    if(!(islower(ch[0])!=0||isupper(ch[0])!=0||ch[0]=='_'))
    {
        printf("no\n");
        return 0;
    }
    else
    {
        for(i=1; ch[i]!='\0'; i++)
        {
            if(islower(ch[i])!=0||isupper(ch[i])!=0||isdigit(ch[i])!=0||ch[i]=='_')
                l=1;
            else
            {
                printf("no\n");
                return 0;
            }

        }
    }
    if(l==1)
        printf("yes\n");
    return 0;
}


猜你喜欢

转载自blog.csdn.net/zzuli_acmer/article/details/78626561