hdu2024——C语言合法标识符

输入一个字符串,判断其是否是C的合法标识符。
Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出”yes”,否则,输出“no”。
Sample Input
3
12ajf
fi8x_a
ff ai_2
Sample Output
no
yes
no

一道很简单的水题卡了半天…不知道为什么gets()一直不能用,然后就只能用了string和getline()

代码:

#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int main(void){
    int t;
    string s;
    scanf("%d",&t);
    getchar();
    while(t--){
        int f=0;
        getline(cin,s);
        int n=s.size();
        if(s[0]=='_'|| s[0]>='a' && s[0]<='z' || s[0]>='A' && s[0]<='Z'){
            for(int i=1;i<n;i++){
                if(s[i]=='_' || s[i]>='0' && s[i]<='9' || s[i]>='a' && s[i]<='z' || s[i]>='A' && s[i]<='Z'){
                    f++;
                }
            }
        }
        if(f==n-1){
            printf("yes\n");
        }
        else{
            printf("no\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/westbrook1998/article/details/80299545
今日推荐