hdu_problem_2024_C语言合法标识符

/*
*
*Problem Description
*输入一个字符串,判断其是否是C的合法标识符。
*
*
*Input
*输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
*
*
*Output
*对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
*
*
*Sample Input
*3
*12ajf
*fi8x_a
*ff  ai_2
*
*
*Sample Output
*no
*yes
*no
*
*
*Author
*lcy
*
*
*Source
*C语言程序设计练习(四)
*
*
*Recommend
*lcy
*
*/
#include<iostream>
#include<string>
using namespace std;
bool is_legal(string s) {
 for (int i = 0; i < s.size(); i++) {
  if ('a' <= s.at(i) && s.at(i) <= 'z' || 'A' <= s.at(i) && s.at(i) <= 'Z' || s.at(i) == '_' || '0' <= s.at(i) && s.at(i) <= '9') {
   continue;
  }
  else {
   return false;
  }
 }
 return true;
}
int main() {
 int n;
 string s;
 cin >> n;
 getchar();
 for (int i = 0; i < n; i++) {
  getline(cin,s);
  if ('a' <= s.at(0) && s.at(0) <= 'z' || 'A' <= s.at(0) && s.at(0) <= 'Z' || s.at(0) == '_') {
   if (is_legal(s))
    cout << "yes\n";
   else
    cout << "no\n";
  }
  else
   cout << "no\n";
 }
 system("pause");
 return 0;
}

猜你喜欢

转载自blog.csdn.net/CoderMaximum/article/details/86171092
今日推荐