C语言合法标识符 HDU - 2024

输入一个字符串,判断其是否是C的合法标识符。 

Input

输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。 

Output

对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。 

Sample Input

3
12ajf
fi8x_a
ff  ai_2

Sample Output

no
yes
no
#include<stdio.h>
#include<string.h>
int main()
{
	char s[101],c;
	int n,i;
	scanf("%d",&n);
	c=getchar();
	while(n--)
	{
		gets(s);
		for(i=1;i<strlen(s);i++)
		{
			if(s[0]=='_'||s[0]<='z'&&s[0]>='a'||s[0]>='A'&&s[0]<='Z')
			{
				if(!(s[i]=='_'||s[i]<='z'&&s[i]>='a'||s[i]>='A'&&s[i]<='Z'||s[i]>='0'&&s[i]<='9'))
				{
				printf("no\n");
				break;
				}
			}
			else
			{
				printf("no\n");
				break;
			}
		}
		if(i==strlen(s))
		printf("yes\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Y_yunhu/article/details/81387736
今日推荐