【水】2024 C语言合法标识符

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)
[显示标签]
Description
输入一个字符串,判断其是否是C的合法标识符。
Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
Sample Input

3
12ajf
fi8x_a
ff  ai_2

Sample Output

no
yes
no

Hint
lcy
Source
  C语言程序设计练习(四)  
Related problem
2028 2032 2023 2029 2025

合法标识符就是只含数字、字母、下划线_,但是数字不能在首位。

输入后遍历、分支判断即可。

代码如下:

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
 int n;
 cin>>n;
 cin.ignore();
 char s[100];
 while(n--){
  cin.getline(s,100);
  int len=strlen(s);
  int j;
  for(j=0;j<len;j++){
   if(!(s[0]>='A'&&s[0]<='Z')&&!(s[0]>='a'&&s[0]<='z')&&s[0]!='_'){
    break;
   }
   if((s[j]>='A'&&s[j]<='Z')||(s[j]>='a'&&s[j]<='z')||(s[j]>='0'&&s[j]<='9')||s[j]=='_')
    continue;
   else{
    break;
   }
  }
  if(j==len)
   cout<<"yes"<<endl;
  else
   cout<<"no"<<endl;
 }
}

猜你喜欢

转载自blog.csdn.net/qq_41627235/article/details/82805666