YTU OJ 1935: C语言合法标识符

Description

输入一个字符串,判断其是否是C的合法标识符。

Input

输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。

Output

对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。

Sample Input

3
12ajf
fi8x_a
ff  ai_2

Sample Output

no
yes
no

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int m = sc.nextInt();
		String t = sc.nextLine();
		while (m > 0) {
			m--;
			String s = sc.nextLine();
			int n = s.length();
			int k = 1;
			if ((s.charAt(0) >= 'a' && s.charAt(0) <= 'z')|| (s.charAt(0) >= 'A' && s.charAt(0) <= 'Z')|| s.charAt(0) == '_')
				for (int i = 1; i < n; i++) {
					if ((s.charAt(i) < '0' || s.charAt(i) > '9')&&(s.charAt(i) < 'a' || s.charAt(i) > 'z')&& (s.charAt(i) < 'A' || s.charAt(i) > 'Z')&& s.charAt(i) != '_')
						k = 0;
				}
			else
				k = 0;
			if (k == 0)
				System.out.println("no");
			else
				System.out.println("yes");
		}
	}
}

猜你喜欢

转载自blog.csdn.net/mcp3128/article/details/81182791