1138 Postorder Traversal(25 分)(C++)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

已知一个二叉树的先序和中序遍历,求其后序遍历的第一个节点。

#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
std::vector<int> pre,in;
bool flag=false;
void postfirst(int instart,int inend,int preroot){
    if(flag==true||instart>inend)
        return;
    int i=instart;
    while(i<inend&&in[i]!=pre[preroot])
        i++;
    postfirst(instart,i-1,preroot+1);
    postfirst(i+1,inend,preroot+i-instart+1);
	if(flag==false){
		printf("%d",in[inend]);
		flag=true;
	}
}
int main(){
    int n;
    scanf("%d",&n);
    pre.resize(n);in.resize(n);
    for(int i=0;i<n;i++)
        scanf("%d",&pre[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&in[i]);
    postfirst(0,n-1,0);
    system("pause");
}
    

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82526070