最大不能组合数和不能组合数的个数

A New Change Problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1609    Accepted Submission(s): 1023
Problem Description
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.
 

Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.
 

Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
 

Sample Input
 
  
2 3 3 4
 

Sample Output
 
  
1 1 5 3
 
题意:求a和b的最大不能组合数和不能组合数的个数

思路:a和b的最大不能组合数为(a-1)*b-a,不能组合数的个数为(a-1)*(b-1)/2

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
	int a,b;
	while(cin>>a>>b)
	{
		cout<<a*b-a-b<<" "<<(a-1)*(b-1)/2<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/luojiushenzi/article/details/80136830