HDU 1198 Farm Irrigation(并查集,自己构造连通条件或者dfs)

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11188    Accepted Submission(s): 4876

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map
ADC
FJK
IHE
then the water pipes are distributed like

Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.
Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?
Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

扫描二维码关注公众号,回复: 1819297 查看本文章

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2 DK HF 3 3 ADC FJK IHE -1 -1

Sample Output

2 3

Author

ZHENG, Lu

Source

Zhejiang University Local Contest 2005


分析:

1.并查集

问你连通图的个数,并查集,但是要自己构造连通条件

连通条件:

对每个方块,看它的左边和上面的方块能否和它连通,能的话就合并

注意方块的边界,比如第0行,就只要看他左边的方块能不能和他合并,不用看上面,因为上面是空的

第0行第0列的方块 跳过

第0行的 只看他左边的

第0列的 只看他上面的

其他的 看左边和上面的

11个方块,一个方块的四条边有管子的就是1,比如A块,1,1,0,0

#include<bits/stdc++.h>
using namespace std;
#define max_v 51
int t[11][4]={1,1,0,0,
0,1,1,0,
1,0,0,1,
0,0,1,1,
0,1,0,1,
1,0,1,0,
1,1,1,0,
1,1,0,1,
1,0,1,1,
0,1,1,1,
1,1,1,1,
};
int sum;
int pa[max_v*max_v];//数组大小需要注意,坑了很多次
int rk[max_v*max_v];
void make_set(int x)
{
    pa[x]=x;
    rk[x]=0;
}
int find_set(int x)
{
    if(x!=pa[x])
       pa[x]=find_set(pa[x]);
       return pa[x];
}
void union_set(int x,int y)
{
    x=find_set(x);
    y=find_set(y);
    if(x==y)
        return ;
    sum--;
    if(rk[x]>rk[y])
    {
        pa[y]=x;
    }else
    {
        pa[x]=y;
        if(rk[x]==rk[y])
            rk[y]++;
    }
}
int main()
{
    int n,m;
    int f[max_v][max_v];
    char c;
    while(~scanf("%d %d",&m,&n))
    {
        getchar();
        if(n==-1&&m==-1)
            break;
       // memset(f,0,sizeof(f));
        sum=n*m;
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                scanf("%c",&c);
                f[i][j]=c-'A';//转换
                make_set(i*n+j);//初始化
                if(i==0&&j==0)
                    continue;
                else if(i==0)
                {
                    if(t[f[i][j-1]][2]&&t[f[i][j]][0])//第0行,判断左
                        union_set(i*n+j,i*n+j-1);
                }
                else if(j==0)//第0列,判断上
                {
                    if(t[f[i][j]][1]&&t[f[i-1][j]][3])
                        union_set(i*n+j,(i-1)*n+j);
                }else
                {
                    // 其他 判断左和上
                    if(t[f[i][j-1]][2]&&t[f[i][j]][0])
                        union_set(i*n+j,i*n+j-1);
                    if(t[f[i][j]][1]&&t[f[i-1][j]][3])
                        union_set(i*n+j,(i-1)*n+j);
                }
            }
            getchar();
        }
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9249736.html