hdu 1198 Farm Irrigation

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11833    Accepted Submission(s): 5117


 

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Figure 1



Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 

Figure 2



Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

 

Output

For each test case, output in one line the least number of wellsprings needed.

 

Sample Input

 

2 2 DK HF 3 3 ADC FJK IHE -1 -1

 

Sample Output

 

2 3

#include<stdio.h>
#include<iostream>
using namespace std;
int  ban[11][4]={{1,0,1,0},{1,0,0,1},{0,1,1,0},{0,1,0,1},{1,1,0,0},{0,0,1,1},{1,0,1,1},{1,1,1,0},{0,1,1,1},{1,1,0,1},{1,1,1,1}};
int  dir[4][2]={{0,-1},{1,0},{0,1},{-1,0}};
int n,m;
struct {
int mark;
char ch;
int up;
int down;
int left;
int right;
} mapp[100][100];
int  judge(int nx,int ny,int x,int y)
{
    if(nx>=0&&nx<n&&ny>=0&&ny<m&&mapp[nx][ny].mark==0)
    {
        if(nx==x&&ny==y-1&&mapp[nx][ny].right==1&&mapp[x][y].left==1)
            return 1;
        else if(nx==x+1&&ny==y&&mapp[nx][ny].up==1&&mapp[x][y].down==1)
            return 2;
        else if(nx==x&&ny==y+1&&mapp[nx][ny].left==1&&mapp[x][y].right==1)
            return 3;
        else if(nx==x-1&&ny==y&&mapp[nx][ny].down==1&&mapp[x][y].up==1)
            return 4;
        else return 0;
    }
    else return 0;
}
void dfs(int x,int y)
{
    mapp[x][y].mark=1;
    for(int i=0;i<4;i++)
    {
        int nx=x+dir[i][0];
        int ny=y+dir[i][1];
        if(judge(nx,ny,x,y)!=0)
         {
             dfs(nx,ny);
         }
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m),n!=-1&&m!=-1)
    {
       int ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
           {
            scanf(" %c",&mapp[i][j].ch);
            char q=mapp[i][j].ch;
            mapp[i][j].mark=0;
            mapp[i][j].up=ban[q-'A'][0];
            mapp[i][j].down=ban[q-'A'][1];
            mapp[i][j].left=ban[q-'A'][2];
            mapp[i][j].right=ban[q-'A'][3];
           }
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
              if(mapp[i][j].mark==0)
              {
                  ans++;
                  dfs(i,j);
              }
              printf("%d\n",ans);
    }return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41661918/article/details/84798259