HDU-1198-Farm Irrigation(dfs)

                                                                                  Farm Irrigation

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

http://acm.hdu.edu.cn/data/images/1121-1.gif

 

Figure 1



Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 

http://acm.hdu.edu.cn/data/images/1121-2.gif

 

Figure 2



Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

 

 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

 

 

Output

For each test case, output in one line the least number of wellsprings needed.

 

 

Sample Input

2 2

DK

HF

 

3 3

ADC

FJK

IHE

 

-1 -1

 

 

Sample Output

2

3

解题思路:

先把每块地的各个方向存起来,然后深搜遍历4个方向,如果相邻的两个方向都通则这两块地是相连的

程序代码:

#include<stdio.h>

#include<string.h>

void dfs(int x,int y);

char s[550][550];

int book[550][550],a[550][550];

int m,n,count;

int main()

{

       int i,j;

       while(scanf("%d%d",&m,&n)!=EOF)

       {

              count=0;

              memset(book,0,sizeof(book));

              if(m==-1&&n==-1)

                     break;

              for(i=0;i<m;i++)

                     for(j=0;j<n;j++)

                     {

                            scanf(" %c",&s[i][j]);

                            a[i][j]=s[i][j]-'A';

                     }

              for(i=0;i<m;i++)

                     for(j=0;j<n;j++)

                            if(book[i][j]==0)

                            {

                                   book[i][j]=1;

                                   count++;

                                   dfs(i,j);

                            }

                                  

              printf("%d\n",count);

       }

       return 0;

}

void dfs(int x,int y)

{

       int next[11][4]={1,1,0,0, 0,1,1,0, 1,0,0,1, 0,0,1,1, 0,1,0,1, 1,0,1,0,

       1,1,1,0, 1,1,0,1, 1,0,1,1, 0,1,1,1, 1,1,1,1};

       int k,tx,ty;

       if(y-1>=0&&next[a[x][y]][0]==1)

              if(book[x][y-1]==0&&next[a[x][y-1]][2]==1)

              {

                     book[x][y-1]=1;

                     dfs(x,y-1);

              }

       if(x-1>=0&&next[a[x][y]][1]==1)

              if(book[x-1][y]==0&&next[a[x-1][y]][3]==1)

              {

                     book[x-1][y]=1;

                     dfs(x-1,y);

              }

       if(y+1<n&&next[a[x][y]][2]==1)

              if(book[x][y+1]==0&&next[a[x][y+1]][0]==1)

              {

                     book[x][y+1]=1;

                     dfs(x,y+1);

              }

       if(x+1<m&&next[a[x][y]][3]==1)

              if(book[x+1][y]==0&&next[a[x+1][y]][1]==1)

              {

                     book[x+1][y]=1;

                     dfs(x+1,y);

              }

       return;

}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81076332