Farm Irrigation zoj 2412(dfs)

Farm Irrigation
Time Limit: 2 Seconds       Memory Limit: 65536 KB

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

结题报告:

一道很简单的题目卡了我几天,这的感觉现在自己弱暴了!需要加油了

其实前几天大致的框架就已经搞定,主要是搜索方向搞错了x+1或x-1时应该往上下搜索,而不是左右,前几次就是错在这了,今后一定要注意!

#include<cstdio>
#include<cstring> 
using namespace std;

int a[13][4]={
1,1,0,0, 0,1,1,0, 1,0,0,1, 0,0,1,1,
0,1,0,1, 1,0,1,0, 1,1,1,0, 1,1,0,1,
1,0,1,1, 0,1,1,1, 1,1,1,1
};
const int maxn = 50 + 5;
int vis[maxn][maxn], mp[maxn][maxn];
const int dir[4][2] = {0,-1,-1,0,0,1,1,0};
int n,m;

void dfs( int x, int y )
{
	vis[x][y] = 1;
	for( int i=0; i<4; i++ )
	{
		int xx = x + dir[i][0];
		int yy = y + dir[i][1];
		if( vis[xx][yy] || xx<0 || xx>=n || yy<0 || yy>=m )
			continue;
		else if( i==0 && a[mp[xx][yy]][2]==1 && a[mp[x][y]][0]==1 )
			dfs( xx, yy );
		else if( i==1 && a[mp[xx][yy]][3]==1 && a[mp[x][y]][1]==1 )
			dfs( xx, yy );
		else if( i==2 && a[mp[xx][yy]][0]==1 && a[mp[x][y]][2]==1 )
			dfs( xx,yy );
		else if( i==3 && a[mp[xx][yy]][1]==1 && a[mp[x][y]][3]==1 )
			dfs( xx, yy);
	}
}

int main( )
{
	char str[maxn];
	while( scanf( "%d%d",&n,&m )!=EOF )
	{
		if( n==-1 && m==-1) break;
		for( int i=0; i<n; i++ )
		{
			scanf( "%s",str );
			for( int j=0; j<m; j++ )
			{
				mp[i][j] = str[j] - 'A';
			}
		}
		memset(vis,0,sizeof(vis)); 
		int ans = 0;
		for( int i=0; i<n; i++ )
		{
			for( int j=0; j<m; j++ )
			{
				if( !vis[i][j] )
				{
					dfs( i, j );
					ans++;
				}
			}
		}
		printf( "%d\n",ans );
	}
	return 0;
}

猜你喜欢

转载自ren-hui.iteye.com/blog/1941622