PAT 1012 The Best Rank

参考自:
https://www.nowcoder.com/questionTerminal/5a5281aef52a4f6f943929c05ba71c11
题目链接:
1012 The Best Rank
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

解题思路:
只说坑点,
(1)该题数据中id均为数字,不含其它字符(用int即可,可以用hash的思想开辟一个大的空间,最后判断id是否出现)
(2)注意到相同的分是一个名次
(3)注意不要用多个结构体来存信息,容易爆内存…
(4)rank在PAT系统里面是关键字…用Rank代替…
(5)胆大心细:)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxv=1000000;
int Rank[maxv][4];
struct stu{
//	char id[100];
	int id;
	int score[4];
}a[maxv];
int p=0;
char lecture[]={'A','C','M','E'};
bool cmp(stu &a1,stu &a2){
	return a1.score[p]>a2.score[p];
}
int main(){
	int n,m;scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++){
		scanf("%d%d%d%d",&a[i].id,&a[i].score[1],&a[i].score[2],&a[i].score[3]);
		a[i].score[0]=a[i].score[1]+a[i].score[2]+a[i].score[3];
	}
	memset(Rank,0,sizeof(Rank));
	for(int i=0;i<4;i++){//科目 
		sort(a,a+n,cmp);
		Rank[a[0].id][i]=1;
		for(int k=1;k<n;k++){//人数 
			if(a[k].score[i]==a[k-1].score[i])  Rank[a[k].id][i]= Rank[a[k-1].id][i];//相同分数 
			else{
				Rank[a[k].id][i]=k+1;
			}
		}
		p++;
	}
	while(m--){
		int id;
		scanf("%d",&id);
		if(!Rank[id][0]) {
			printf("N/A\n");
			continue;
		}
		
		int _min=0x7ffffff,_ind=-1;
		for(int k=0;k<4;k++){
			if(Rank[id][k]<_min){
				_min=Rank[id][k];
				_ind=k;
			}
		}
		printf("%d %c\n",_min,lecture[_ind]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zhuixun_/article/details/83029085