A+B的系列问题四

题目描述

Your task is to Calculate the sum of some integers. 

输入

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed. 

输出

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

样例输入

4 1 2 3 4
5 1 2 3 4 5
0 

样例输出

10
15

时间限制: 1 Sec 内存限制: 128 MB

代码实现:

#include<stdio.h>

int main()
{
    int n = 0;
    int sum = 0;
    int temp = 0;
    while((scanf("%d", &n) != EOF), (n != 0))
    {
        sum = 0;
        while(n--)
        {
            scanf("%d", &temp);
            sum += temp;
        }
        printf("%d\n", sum);
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/eric_qiushui/article/details/79503734
今日推荐