A+B的系列问题八

题目描述

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n. 

输入

The input will consist of a series of integers n, one integer per line.

输出

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

样例输入

1
100

样例输出

1

5050

时间限制: 1 Sec 内存限制: 128 MB

代码实现:

#include<stdio.h>  

int main()
{  
    int n;  
    while(~scanf("%d", &n))
    {  
        int sum = 0;  
        while(n)
        {  
            sum += n;  
            n--;  
        }  
        printf("%d\n\n", sum);  
    }  
    return 0;  
} 

猜你喜欢

转载自blog.csdn.net/eric_qiushui/article/details/79503870
今日推荐