A+B的系列问题l七

题目描述

Your task is to calculate the sum of some integers. 

输入

Input contains an integer N in the first line, and then N lines follow. 
Each line starts with a integer M, and then M integers follow in the same line. 

输出

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs. 

样例输入

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

样例输出

10

15

6

时间限制: 1 Sec 内存限制: 128 MB

代码实现:

#include<stdio.h>

int main()
{
    int num = 0;
    int n = 0;
    int sum = 0;
    int temp = 0;
    scanf("%d", &num);
    while(num--)
    {
        sum = 0;
        scanf("%d", &n);
        while(n--)
        {
            scanf("%d", &temp);
            sum += temp;
        } 
        if(num == 0)
        {                
            printf("%d\n", sum);  
        }
        else 
        {  
            printf("%d\n\n", sum);             
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/eric_qiushui/article/details/79503838