A+B的系列问题六

题目描述

Your task is to calculate the sum of some integers.

输入

Input contains multiple test cases, and one case one line.
 Each case starts with an integer N, and then N integers follow in the same line. 

输出

For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 

样例输入

4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

时间限制: 1 Sec 内存限制: 128 MB

代码实现:

#include<stdio.h>  
int main()
{  
    int n = 0;
    int sum = 0;
    int temp = 0;  
    while(scanf("%d", &n) != EOF)
    {  
        sum = 0;  
        while(n--)
        {  
            scanf("%d", &temp);  
            sum += temp;  
        }  
        printf("%d\n", sum);  
    }  
    return 0;  
}

猜你喜欢

转载自blog.csdn.net/eric_qiushui/article/details/79503805
今日推荐