PAT 1074 Reversing Linked List 链表

链表处理问题
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100010;
struct Node{
	int address,val,next;
	int order;
}node[maxn];
bool cmp(Node a,Node b){
	return a.order<b.order;
}
int main(){
	for(int i=0;i<maxn;i++)
		node[i].order=maxn;
	int N,K,begin;
	scanf("%d%d%d",&begin,&N,&K);
	for(int i=0;i<N;i++){
		int address;
		scanf("%d",&address);
		scanf("%d%d",&node[address].val,&node[address].next);
		node[address].address=address;
	}
	int p=begin;
	int cnt=0;
	while(p!=-1){
		node[p].order=cnt;
		//printf("%05d %d %d\n",node[p].address,node[p].val,node[p].next);
		p=node[p].next;
		cnt++;
	}
	sort(node,node+maxn,cmp);	
	//这一步不写会错最后一个1分的测试用例 
	//要去掉无效阶段 就是多余的结点 不会在链上面出现的 
	N=cnt;
	int group=N/K;
	for(int i=0;i<group;i++){
		for(int j=(i+1)*K-1;j>i*K;j--){
			printf("%05d %d %05d\n",node[j].address,node[j].val,node[j-1].address);
		}
		printf("%05d %d ",node[i*K].address,node[i*K].val);
		//后面还有组 
		if(i<group-1){
			printf("%05d\n",node[(i+2)*K-1].address);
		}
		//已经是最后一组 
		else{
			if(N%K==0){
				printf("-1\n"); 
			}
			else{
				printf("%05d\n",node[(i+1)*K].address);
				//最后一组顺序输出
				for(int j=N/K*K;j<N;j++){
					printf("%05d %d ",node[j].address,node[j].val);
					if(j<N-1)
						printf("%05d\n",node[j+1].address);
					else
						printf("-1\n");
				}
			}
		}
	}
}
发布了9 篇原创文章 · 获赞 3 · 访问量 262

猜你喜欢

转载自blog.csdn.net/weixin_39666736/article/details/96461440