hdu 6168 Numbers

zk has n numbers a1,a2,...,an. For each (i,j) satisfying 1≤i<j≤n, zk generates a new number (ai+aj). These new numbers could make up a new sequence b1b2,...,bn(n1)/2

.
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
InputMultiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each ai is in [1,10^9]
OutputFor each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers a1,a2,...,an(a1a2...an). These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.Sample Input
6
2 2 2 4 4 4
21
1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
Sample Output
3
2 2 2
6
1 2 3 4 5 6
记录每个数出现的次数,把所有数从小到大排序,前两个数肯定是序列里的,因为是最小的,然后排着把已知序列里的值两两相加,如果 得到的值的次数不为0,就让次数-1,排着把次数为1的数找出来就是答案。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <map>
using namespace std;
int m,n,s[200000],ans[200000];///ans存要求的序列
int main()
{
    while(scanf("%d",&m) != EOF)
    {
        map<int,int> q;
        n = 0;
        for(int i = 0;i < m;i ++)
        {
            scanf("%d",&s[i]);
            q[s[i]] ++;
        }
        sort(s,s + m);
        for(int i = 0;i < m;i ++)
        {
            if(!q[s[i]])continue;///次数为0,就略过
            for(int j = 0;j < n;j ++)///依次跟ans里的值相加来消除后边的数
            {
                q[s[i] + ans[j]] --;
            }
            ans[n ++] = s[i];
            q[s[i]] --;//防止重复的数读进去,需把次数-1
        }
        printf("%d\n",n);
        for(int i = 0;i < n;i ++)
        {
            if(i)putchar(' ');
            printf("%d",ans[i]);
        }
        putchar('\n');
    }
}

猜你喜欢

转载自www.cnblogs.com/8023spz/p/9002306.html
今日推荐