HDU 6168 Numbers【水题】

Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 356    Accepted Submission(s): 180


Problem Description
zk has n numbers  a1,a2,...,an. For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj). These new numbers could make up a new sequence  b1b2,...,bn(n1)/2.
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an). These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
 
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
 
  
3 2 2 2 6 1 2 3 4 5 6
 

Source
题意:

给你两个序列A,B,序列B中的数是A中任意两个数的和。现在给出你A,B序列混在一起的数,让你找出A序列输出。

思路:

每次加进去一个筛掉后最小的数,然后与前面已经有的数把剩下的数筛一下就好。

#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;

const double pi = acos(-1.0);
const int mod = 1e9 + 7;
const int maxn = 125350;

int a[maxn], ans[maxn];

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	int n;
	while (~scanf("%d", &n))
	{
		map<int, int> mp;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", a + i);
			mp[a[i]]++;
		}
		int num = 0;
		for (int i = 0; i < n; i++)
		{
			if (mp[a[i]])	//加进去与前面有的筛一下就好
			{
				mp[a[i]]--;
				ans[num++] = a[i];
				for (int k = num - 2; k >= 0; k--)
					if (mp[ans[num - 1] + ans[k]])
						mp[ans[num - 1] + ans[k]]--;
			}
		}
		printf("%d\n", num);
		for (int i = 0; i < num; i++)
		{
			cout << ans[i];
			if (i != num - 1) printf(" ");
		}
		puts("");
	}
	return 0;
}


 
 

 
 

发布了123 篇原创文章 · 获赞 62 · 访问量 6万+

猜你喜欢

转载自blog.csdn.net/Archger/article/details/77488275