HDU - 3714 Error Curves

问题描述:

Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm’s efficiency, she collects many datasets.
What’s more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset’s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

It’s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function’s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1…n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem. As a super programmer, can you help her?

输入说明:

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

输出说明:

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

SAMPLE INPUT:

2
1
2 0 0
2
2 0 0
2 -4 2

SAMPLEOUTPUT:

0.0000
0.5000

思路:

题意:已知n个二次曲线Si(x) = aix^2+bix+c(ai >= 0),定义F(x) = max(Si(x)),求出F(x)在[0, 1000]上的最小值,这里采用三分的办法,先定义一个函数用来求函数F(x)在当前位置的值以及进行比较,得到当前的最小值。然后以0为起点,1000为终点,进行三分。(注意这道题对精度的要求很高,需要1e-11的精度)

AC代码:

#include <bits/stdc++.h>
using namespace std;
double a[10000],b[10000],c[10000];
int n;
double check(double x)
{
    
    
    double ans=a[0]*x*x+b[0]*x+c[0];
    for(int i=1;i<n; i++)
    {
    
    
        ans=max(ans,a[i]*x*x+b[i]*x+c[i]);
    }
    return ans;
}
int main()
{
    
    
    int t,i;
    cin>>t;
    while(t--)
    {
    
    
        cin>>n;
        for(int i=0; i<n; i++)
        {
    
    
            scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
        }
        double left,right;
        left=0.0;
        right=1000.0;
        while(left+1e-11<right)
        {
    
    
            double middle1=(left+right)/2;
            double middle2 = (middle1+right)/2;
            if(check(middle1)>check(middle2))
                left=middle1;
            else
                right=middle2;
        }
        cout<<fixed<<setprecision(4)<<check(right)<<endl;
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/m0_51727949/article/details/115185426