【HDU - 3714】【Error Curves】

版权声明:本人原创,未经许可,不得转载 https://blog.csdn.net/qq_42505741/article/details/82077984

题目:

Josephina is a clever girl and addicted to Machine Learning recently. She 
pays much attention to a method called Linear Discriminant Analysis, which 
has many interesting properties. 
In order to test the algorithm's efficiency, she collects many datasets. 
What's more, each data is divided into two parts: training data and test 
data. She gets the parameters of the model on training data and test the 
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0. 



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

题意:给我们多组抛物线,然后我们把其合成最大的一个曲线,输出其的值最小点。

解题思路:三分操作的plus,增加了一步寻找最大的值的操作。

ac代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define eps 1e-10
#define maxn 10008
using namespace std;
int  a[maxn],b[maxn],c[maxn];
int n;
double cal(double x)
{
	double y=a[0]*x*x+b[0]*x+c[0];
	for(int i=1;i<n;i++)
		y=max(y,a[i]*x*x+b[i]*x+c[i]);
	return y;	
} 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&a[i],&b[i],&c[i]);
		}
		double rmin=0,rmax=1000;
		while(rmax-rmin>eps)
		{
			double mid=rmin+(rmax-rmin)/3;
			double midd=rmax-(rmax-rmin)/3;
			if(cal(mid)<cal(midd)) rmax=midd;
			else rmin=mid;
		}
		double ans=cal(rmin);
		printf("%.4lf\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/82077984