Java Beans ZOJ - 3714

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?


Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ MN). Here N and M are defined in above description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input
2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75
Sample Output
16
158


AC代码(sum的初值要放对位置)

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main()
{
    int t, n, m, a[1000+10], b[1000+10], sum, maxi, i, j;
    cin>>t;
    while(t--)
    {
     sum = 0, maxi = 0;
     cin>>n>>m;
     for(i = 0;i<n;i++)
     {
      cin>>a[i];
      b[i] = a[i];
     }
     if(n==m)
     {
      for(i = 0;i<n;i++)
      {
       sum = sum + a[i];
      }
      cout<<sum<<endl;
     }
     else
     {
      for(i = 0;i<n;i++)
      {
       a[i+n] = b[i];
      }
      for(i = 0;i<=2*n-m;i++)
      {
        sum = 0;
       for(j = 0;j<m;j++)
       {
        sum = sum + a[i+j];
       }
       if(maxi<sum)
       {
        maxi = sum;
       }
      }
       cout<<maxi<<endl;
      }
     }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41524782/article/details/80787032
ZOJ