5.5 PAT A1096 Consecutive Factors (20分)(连续质因子)

1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题意为求给定数中是否有一段连续整数的乘积,可以被N整除。给出最大长度及乘积。

参考代码:

#include <cstdio>
#include <cmath>
#include <algorithm>
typedef long long ll;
int main()
{
	ll n;
	while(scanf("%lld",&n)!=EOF)
	{
		ll sqr=(ll)sqrt(1.0*n);
		ll ansi=0,anslen=0; //ansi记录质因子起始位置,anslen记录区间长度 
		for(ll i=2;i<=sqr;++i) //寻找质因子 
		{
			ll temp=1,j=i;//temp记录当前整数乘积,j为连续取值 
			while(1)
			{
				temp*=j;
				if(n%temp!=0) //非因子,退出 
					break;
				if(j-i+1>anslen) //有更长の区间,更新 
				{
					ansi=i;
					anslen=j-i+1;
				}
				j++;	
			}
		}
		if(anslen==0)
			printf("1\n%lld\n",n);
		else
		{
			printf("%lld\n",anslen);
			for(ll i=0;i<anslen;++i)
			{
				printf("%lld",ansi+i);
				if(i<anslen-1)
					printf("*");
			}
			printf("\n");
		}
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_43590614/article/details/105199600