(难)A1096 Consecutive Factors (20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

题意:

给出一个正整数N(1<N<2^​31​​),求一段连续的整数,使得N能够被这段连续整数的乘积整除。如果有多个方案,输出连续整数个数最多的方案;如果还有多种方案,输出其中第一个数最小的方案。

思路:

本题的思路比较难想,想要找到连续整数最多的那一个,就设变量连续整数长度ansLen和对应的第一个整数ansI,枚举数字,判断是否满足情况,不断更新这两个值。

值得注意的是,N 不会被除自己以外的大于sqrt(N) 的整数整除,因此要从 2~ sqrt(N) 遍历连续整数的第一个。

如果遍历结束后,ansLen == 0, 那么说明不超过sqrt(N)不存在连续的整数,因此答案就是N本身

注意:

  1. 需要用long long ,防止中间成绩超过 int 导致溢出

#include <cstdio>
#include <cmath>
#include <algorithm>
typedef long long ll;
int main(){
  ll n;
  scanf("%lld", &n);
  ll sqr = (ll)sqrt(1.0 * n), ansI = 0, ansLen = 0;
  for(ll i = 2; i <= sqr; i++){   //在2~sqrt(n)中枚举序列的第一个整数
    ll temp = 1, j = i;
    while(1){
      temp *= j;
      if(n % temp != 0)   //寻找满足条件的连续序列
        break;
      if(j - i + 1 > ansLen){
        ansI = i;
        ansLen = j - i + 1;
      }
      j++;    //j不断增大,序列中最后一个
    }
  }
  if(ansLen == 0){
    printf("1\n%lld", n);
  }
  else{
    printf("%lld\n", ansLen);
    for(ll i = 0; i < ansLen; i++){
      printf("%lld", ansI + i);
      if(i < ansLen - 1){
        printf("*");
      }
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/86704366