1096 Consecutive Factors (20)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^31^).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

其他一些易错的测试点:

969353378 、 2、 13

#include<stdio.h>
#include<cmath>
typedef long long ll;
int main() {
    ll n, Len = 0, sign;
    scanf("%lld", &n);
    ll sqr = (ll)sqrt(1.0 * n);
    for (ll i = 2; i <= sqr; ++i) {
        ll ans = n,anslen = 0;
        ll start = i;
        while (ans % start == 0) {  
            ++anslen;
            ans /= start;
            ++start;
        }
        if (anslen > Len) {   //不带“=”!!!找了好久啊噗!!!
            Len = anslen;
            sign = i;
        }
    }
    if (Len == 0) printf("1\n%lld", n);    //注意遍历后Len仍然为0的情况!!!
    else {
        printf("%lld\n", Len);
        for (ll i = 0; i < Len; ++i) {
            if (i != 0) printf("*");
            printf("%lld", sign + i);
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Yaxadu/p/9175477.html