PAT.A1096 Consecutive Factors

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^31^).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
typedef long long ll;
using namespace std;
const int maxn = 100010;

int main() {
	ll n;
	scanf("%lld", &n);
	ll ansi=0, ansl = 0, tansi, tansl = 0;
	ll sqr = (ll)sqrt(1.0*n);
	ll sum;
	for (ll i = 2; i <= sqr; i++) {
		sum=1;
		if (tansl == 0) tansi = i;
		do{
			sum *= tansi;
			tansi++;
			tansl++;
			//printf("%d %d\n",tansi,tansl);
		}while (n%sum == 0);
		if (--tansl > ansl) {
				ansl = tansl;
				ansi = i;
		}
		tansl = 0;
		}
	if (ansl == 0) printf("1\n%lld", n);
	else {
		printf("%lld\n", ansl);
		for (ll i = ansi; i < ansi + ansl; i++) {
			printf("%lld", i);
			if (i < ansi + ansl - 1) printf("*");
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/mokena1/article/details/80736997