PAT:A1096 Consecutive Factors (20 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/82664788

PAT:A1096 Consecutive Factors (20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;

int main() {
	// 要定义连续整数的初始整数lenI, 长度len 以及输入的数字N 
	ll n, lenI = 0, len = 0;
	scanf("%lld", &n);
	ll q = (ll)sqrt(1.0 * n);
	for(ll i = 2; i <= q; i++) {
		int temp = 1, j = i;
		while(1) {
			temp *= j;
			if(n % temp != 0) break;
			if(j-i+1 > len) {
				lenI = i;
				len = j - i + 1;
			}
			j++; 
		}
	}
	if(len == 0) {
		printf("1\n%lld", n);
	} else {
		printf("%lld\n", len);
		for(int i = 0; i < len; i++) {
			printf("%lld", lenI+i);
			if(i < (len-1)) printf("*");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/82664788