【差分约束】poj 3169 Layout

Layout

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19649   Accepted: 9435

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

直接差分约束,然后有负环->-1 dis[n]==inf -> -2

代码

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
const int maxn=1005;
const int maxm=2e5+5;
const int inf=0x3f3f3f3f;
int n,m,mm,head[maxn],cnt,dis[maxn];
struct edge
{
	int to,nxt,v;
}e[maxm];
void add(int x,int y,int z)
{
	e[++cnt].to=y;
	e[cnt].nxt=head[x];
	e[cnt].v=z;
	head[x]=cnt;
}
int vis[maxn];
int spfa()
{
	for(int i=2;i<=n;i++) dis[i]=inf;
	queue <int> q;
	q.push(1); vis[1]=1;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i;i=e[i].nxt)
		{
			int to=e[i].to;
			int v=e[i].v;
			if(dis[to]>dis[u]+v)
			{
				dis[to]=dis[u]+v;
				q.push(to);
				vis[to]++;
			}
			if(vis[to]>n) return 1;
		}
	}
	return 0;
}
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	scanf("%d%d%d",&n,&m,&mm);
	int x,y,z;
	for(int i=1;i<=m;i++)
	{
		scanf("%d%d%d",&x,&y,&z);
		add(x,y,z);
	}
	for(int i=1;i<=mm;i++)
	{
		scanf("%d%d%d",&x,&y,&z);
		add(y,x,-z);
	}
	if(spfa()) printf("-1");
	else
	{
		if(dis[n]==inf) printf("-2");
		else printf("%d",dis[n]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/andyc_03/article/details/109992820
今日推荐