【poj-3169】Layout (差分约束+spaf)

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

参考博客

差分约束系统:https://blog.csdn.net/consciousman/article/details/53812818

思路:

说实话,这道题过的佷蒙,自己都不知道怎么水过的,开始什么思路都没有,想过dijsktra算法和拓扑排序但感觉都不合适。

最后看了差分约束系统,感觉有思路了。这里要注意的就是在两个不同的for循环中加边的顺序是不同的。因为这道题要求最大距离,即最短路径,这样不等式全部化成xi-xj<=k的形式。接下来就是用spaf算法求解,如果有环,就是无解。无环的话,就一定有解,但两个端点如果没有关系(不论直接、间接),那么就说明这个解可能有多个,dis数组返回的n的值也就是0x3f3f3f3f(这样初始化的)。否则返回一个具体的值就是有解。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring> 
#include<queue>
#include<sstream>
#include<stack> 
#include<string.h>
#include<set>
#include<map> 
#define PI acos(-1.0)
#define eps 1e-8
#define ll long long
#define MAX 0x3f3f3f3f
using namespace std;
struct node
{
	int id;
	int w;
	int next;
}side[12000];
int head[1000];
int book[12000];
int dis[12000];
int n,m,f;
int cnt=0;
void init()
{
	memset(book,0,sizeof(book));
	memset(dis,0x3f3f3f3f,sizeof(dis));
	memset(head,-1,sizeof(head));
	cnt=0;
}
void add(int x,int y,int w)
{
	side[cnt].id=y;
	side[cnt].w=w;
	side[cnt].next=head[x];
	head[x]=cnt++;
}

int main()
{
	int n,ml,md;
	
	while(~scanf("%d%d%d",&n,&ml,&md))
	{
		init();
		int a,b,d;
		//下面注释的for循环本是想找一个点保证这个图连通,但这道题加不加都对 
		//for(int i=1;i<=n;i++)
		//{
		//	add(0,i,0);
		//} 
		for(int i=0;i<ml;i++)
		{
			scanf("%d%d%d",&a,&b,&d);
			add(min(a,b),max(a,b),d); //大-小<=d,add(小,大,d)
		}
		for(int i=0;i<md;i++)
		{
			scanf("%d%d%d",&a,&b,&d);
			add(max(a,b),min(a,b),-d); //大-小>=d,化成小-大<=-d,add(大,小,d)
		}
		int flag=0;
		int cn[10000];//入队列几次 
		memset(cn,0,sizeof(cn));
		queue<int > q;
		q.push(1);
		dis[1]=0;
		book[1]=1;
		cn[1]=1;
		while(!q.empty())
		{
			int u=q.front();
			q.pop();
			book[u]=0;
			for(int i=head[u];i!=-1;i=side[i].next)
			{
				if(dis[side[i].id]>dis[u]+side[i].w)
				{
					dis[side[i].id]=dis[u]+side[i].w;
					if(book[side[i].id]==0)
					{
						cn[side[i].id]++;
						if(cn[side[i].id]>=n)
						{
							flag=1;
							break;
						}
						book[side[i].id]=1;
						q.push(side[i].id);
					} 
				}
			}
			if(flag)break;
		} 
		//最小路径-最大距离
		//任意--有解,但返回距离是最大值 两边无直接关系,也就是从起点不能优化到终点 
		//无解---环
		if(flag)
			printf("-1\n");//无解 
		else if(dis[n]==0x3f3f3f3f)
		printf("-2\n");// 有解但解不唯一 
		else
		printf("%d\n",dis[n]);//有唯一解 
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/QQ_774682/article/details/81360868