POJ3169 Layout(差分约束应用+SPFA)

题目链接

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1…N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
————————————————
Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2…ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2…ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
————————————————
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
————————————————
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3

Sample Output
27
(之前差分约束没有学会,导致现在又得花更多的时间。QAQ)

思路

本题为差分约束与判负环的结合,由题目可知对于 a-b<=x; c-d>=y,两式符号不同,因此需要做出一些改变使得结果求取更加方便。令二式乘-1,则其变为d-c<=-y,这样的不等式条件下便可以使用SPFA获取最短路了。

代码

#include<map>
#include<stack>
#include<queue>
#include<string>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define pb push_back
using namespace std;
const int maxn=1e5+5;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int minn=0xc0c0c0c0;
bool vis[maxn];
int n,m,k,u,v,w,dis[maxn],num[maxn];
struct node
{
    
    
	int v,w;
};
queue<int>que;
vector<node>a[maxn];
void spfa()
{
    
    
	memset(num,0,sizeof num);
	memset(dis,inf,sizeof dis);
	memset(vis,false,sizeof vis);
	dis[1]=0;
	num[1]++;
	que.push(1);
	while(!que.empty())
	{
    
    
		int u=que.front();
		vis[u]=false;
		que.pop();
		for(int i=0;i<a[u].size();i++)
		{
    
    
			int v=a[u][i].v,w=a[u][i].w;
			if(dis[v]>dis[u]+w)
			{
    
    
				dis[v]=dis[u]+w;
				if(!vis[v])
				{
    
    
					num[v]++;
					if(num[v]>=n)
					{
    
    
						cout<<"-1"<<endl;
						return ;
					}
					que.push(v);
					vis[v]=true;
				}
			}
		}
	}
	if(dis[n]==inf)
		cout<<"-2"<<endl;
	else
		cout<<dis[n]<<endl;
	return ;
}
int main()
{
    
    
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);
    cin>>n>>m>>k;
    for(int i=0;i<m;i++)
    {
    
    
    	cin>>u>>v>>w;
    	a[u].pb({
    
    v,w});
    	a[v].pb({
    
    u,w});
	}
	for(int i=0;i<k;i++)
	{
    
    
		cin>>u>>v>>w;
		a[v].pb({
    
    u,-w});
	}
	spfa();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/WTMDNM_/article/details/108682282
今日推荐