Layout POJ - 3169 (差分约束)

版权声明: https://blog.csdn.net/nucleare/article/details/89740118

Layout

 POJ - 3169 

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

#include <algorithm>
#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
using namespace std;
#define ll long long
const int N = 1e3 + 7;
const int M = 1e6 + 7;
const ll INF = 0x3f3f3f3f3f3f3f3f;
int head[N], en;
struct Edge {
	int v, to;
	ll w;
} e[M];
void adde(int u, int v, ll w) {
	e[++en].v = v;
	e[en].w = w;
	e[en].to = head[u];
	head[u] = en;
}
void init(int n) {
	memset (head, -1, sizeof(head)); en = 0; 
}
ll dis[N];
int in[N], times[N];
int flag = 0;
void SPFA(int n) {
	queue<int> q;
	memset(dis, 0x3f, sizeof(dis));
	memset(in, 0, sizeof(in));
	memset(times, 0, sizeof(times));
	dis[1] = 0;
	in[1] = 1;
	times[1] = 1;
	q.push(1);
	while (!q.empty()) {
		
		int u = q.front();
		for (int i = head[u]; ~i; i = e[i].to) {
			int v = e[i].v;
			if (dis[v] > dis[u] + e[i].w) {
				dis[v] = dis[u] + e[i].w;
				if (!in[v]) {
					if (times[v] > n) {
						flag = 1;
						break;
					}
					q.push(v);
					++times[v];
					in[v] = 1;
				}
			}
		}
		in[u] = 0;
		q.pop();
	} 
	
}

int main() {
	
	int n, ml, md;
	while (~scanf ("%d %d %d", &n, &ml, &md)) {
		// v - u <= w  =>>  v <= w + u
		int u, v;
		ll w;
		init(n);
		for (int i = 1; i <= ml; ++i) {
			scanf ("%d %d %lld", &u, &v, &w);
			adde(u, v, w);
		}
		// v - u => w  =>>  v >= w + u =>>  -v <= w + u
		for (int i = 1; i <= md; ++i) {
			scanf("%d %d %lld", &u, &v, &w);
			adde(v, u, -w);
		}
		flag = 0;
		SPFA(n);
		if (dis[n] >= INF) {
			puts("-2");  //可以是任意远 
		} else if (flag) {
			puts("-1");  //不可达(无方案) 
		} else {
			printf ("%lld\n", dis[n]);
		}
		
	}
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/89740118
今日推荐