【POJ3169】Layout(差分约束系统+SPFA)

题目链接

Layout

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions:14919   Accepted: 7183

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

USACO 2005 December Gold

【题意】

有n只牛排成一排,有ML条数据表示A,B两只牛之间的距离不能超过D,A,有MD条数据表示A,B两只牛之间的距离不能小于D,求第一只牛和第n只牛之间的最大距离。

【解题思路】

对应ml条信息:

①牛A和牛B的距离不想超过D,那么建立不等式:A-B<=D;加入到图中直接add(A,B,D)即可。

对应md条信息:

②牛A和牛B的距离至少要为D,那么建立不等式:A-B>=D,那么我们左右两边同乘-1有:B-A<=-D,那么加入到图中add(B,A,-D)即可。

图建立好之后直接跑最短路即可。

①如果dis[n]=INF,说明终点不可达,输出-2。

②如果路径中存在负环,说明最短路可以无限小,即不存在最短路,输出-1。

③其余情况则输出答案。

【代码】

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=1e4+5;
const int INF=0x3f3f3f3f;
int n,ml,md,cnt=0;
struct Node
{
    int to,next,w;
}node[2*maxn];
int vis[maxn],dis[maxn],head[maxn],out[maxn];
void add(int from,int to,int w)
{
    node[cnt].to=to;
    node[cnt].w=w;
    node[cnt].next=head[from];
    head[from]=cnt++;
}
void spfa()
{
    for(int i=1;i<=n;i++)
        dis[i]=INF;
    dis[1]=0;
    queue<int>q;
    q.push(1);
    int flag=0;
    while(!q.empty())
    {
        int u=q.front();
        out[u]++;
        q.pop();
        if(out[u]>n)//存在负环
        {
            flag=1;
            break;
        }
        vis[u]=0;
        for(int i=head[u];i!=-1;i=node[i].next)
        {
            int v=node[i].to;
            int w=node[i].w;
            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(vis[v]==0)
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
    }
    if(flag)printf("-1\n");
    else
    {
        if(dis[n]==INF)printf("-2\n");
        else printf("%d\n",dis[n]);
    }
}
int main()
{
    int x,y,w;
    memset(head,-1,sizeof(head));
    scanf("%d%d%d",&n,&ml,&md);
    for(int i=0;i<ml;i++)
    {
        scanf("%d%d%d",&x,&y,&w);
        add(x,y,w);
    }
    for(int i=0;i<md;i++)
    {
        scanf("%d%d%d",&x,&y,&w);
        add(y,x,-w);
    }
    spfa();
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/82925970
今日推荐