畅通工程续

畅通工程续

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1
采用floyed算法
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAXN=999999;

int N,M,m[220][220],s,t;

int main()
{
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        for(int i=0;i<=N-1;i++)
        {
            m[i][i]=0;
            for(int j=i+1;j<=N-1;j++)
                m[i][j]=m[j][i]=MAXN;
        }
        for(int i=1;i<=M;i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            if(z<m[x][y]) m[x][y]=m[y][x]=z;
        }
        scanf("%d%d",&s,&t);
        for(int k=0;k<=N-1;k++)
            for(int i=0;i<=N-1;i++)
                for(int j=0;j<=N-1;j++)
                {
                    if(m[i][j]>m[i][k]+m[k][j])
                        m[i][j]=m[i][k]+m[k][j];
                }
        if(m[s][t]==MAXN) printf("-1\n");
        else printf("%d\n",m[s][t]);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wanghaixv/p/8998761.html