A - 畅通工程续 最短路

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。Output对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input

3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

Sample Output

2
-1


首先可以知道这是一个没有负环的最短路,然后建图用dijkastra就可以了

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=1100;
int d[maxn],n,m;
bool vis[maxn];
struct edge
{
	int from,to,dist;
	edge(int from,int to,int dist):from(from),to(to),dist(dist){}
};
struct heapnode
{
	int d,u;
	heapnode(int d,int u) : d(d),u(u) {}
	bool operator<(const heapnode &a) const{
	    return a.d<d;
	}
};

queue<edge>q[maxn];

void dijkstra(int s)
{
	priority_queue<heapnode>que;
	for(int i=0;i<=n;i++) d[i]=inf;
	d[s]=0;
	memset(vis,0,sizeof(vis));
	que.push(heapnode(0,s));
	while(!que.empty())
	{
		heapnode x=que.top();que.pop();
		int u=x.u;
		if(vis[u]) continue;
		vis[u]=1;
		while(!q[u].empty())
		{
			edge e=q[u].front();
			q[u].pop();
			if(d[e.to]>d[u]+e.dist)
			{
				d[e.to]=d[u]+e.dist;
				que.push(heapnode(d[e.to],e.to));
			}
		}
	}
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(int i=0;i<n;i++) while(!q[i].empty()) q[i].pop();
		for(int i=0;i<m;i++)
		{
		    int a,b,x;
		    scanf("%d%d%d",&a,&b,&x);
		    q[a].push(edge(a,b,x));
		    q[b].push(edge(b,a,x));
		}
		int s,t;
		scanf("%d%d",&s,&t);
		dijkstra(s);
		if(d[t]>=inf) printf("-1\n");
		else printf("%d\n",d[t]);
	}
	return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/EchoZQN/p/10424244.html