PAT(乙级)2019年冬季考试 7-3 String复读机 (20分)

7-3 String复读机 (20分)

给定一个长度不超过 10
​4
​​ 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 StringString… (注意区分大小写)这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 String 的顺序打印,直到所有字符都被输出。例如 gnirtSSs 要调整成 StringS 输出,其中 s 是多余字符被忽略。

输入格式:
输入在一行中给出一个长度不超过 10
​4
​​ 的、仅由英文字母构成的非空字符串。

输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
sTRidlinSayBingStrropriiSHSiRiagIgtSSr

输出样例:
StringStringSrigSriSiSii

#include <iostream>
#include <vector>
#include <stdio.h>
using namespace std;
int main(){
	string temp;
	string a="String";
	vector<int> count(6,0);
	
	getline(cin,temp);
	int total=0;
	for(int i=0;i<temp.length();i++){
		for(int j=0;j<6;j++){
			if(temp[i]==a[j]){
				count[j]++;
				total++;
				break;
			}
		}
	}
	while(total!=0){
		for(int i=0;i<6;i++){
			if(count[i]>0){
				printf("%c",a[i]);
				count[i]--;
				total--;
			}
		}
	}
	return 0;
}

发布了5 篇原创文章 · 获赞 0 · 访问量 18

猜你喜欢

转载自blog.csdn.net/kid1402/article/details/104483721