POJ 1050【最大子矩阵】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/81906610

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 
0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 
9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

最大子矩阵讲解请看大佬链接https://www.cnblogs.com/GodA/p/5237061.html

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <stack>
#define INF 0x3f3f3f3f
//#include <bits/stdc++.h>
using namespace std;
const int maxn=100010;
int maxsub(int arr[], int n){
    int b=0,maxx=0;
    for(int i=0;i<n;i++){
        if(b>0) b+=arr[i];
        else b=arr[i];
        maxx=max(b, maxx);
    }
    return maxx;
}
int main()
{
    int dp[110][110],arr[110];
    int n;
    while(~scanf("%d", &n)){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                scanf("%d", &dp[i][j]);
            }
        }
        int maxrec=0;
        for(int i=0;i<n;i++){
            memset(arr,0,sizeof arr);
            for(int j=i;j<n;j++){
                for(int k=0;k<n;k++){
                    arr[k]+=dp[j][k];
                }
                maxrec=max(maxrec,maxsub(arr,n));
            }
        }
        printf("%d\n",maxrec);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/81906610