PAT甲级1012 (结构体,排序)

题目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C – C Programming Language, M – Mathematics (Calculus or Linear Algebra), and E – English. At the mean time, we encourage students by emphasizing on their best ranks — that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A – Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


题解

#include<cstdio>
#include<algorithm>
using namespace std;
struct student{
  int id;
  int score[4];//每个人每门课的分数,每门课的排名
}stu[2010];

int Rank[1000000][4]={0};//初始化排名为0
int course;
bool cmp(student a,student b){
  return a.score[course]>b.score[course];
}
char k[4]={'A','C','M','E'};

int main(){
  int n,m;
  int q;
  scanf("%d %d",&n,&m);
  for(int i=0;i<n;i++){
    scanf("%d%d%d%d",&stu[i].id,&stu[i].score[1],&stu[i].score[2],&stu[i].score[3]);
    stu[i].score[0]=stu[i].score[1]+stu[i].score[2]+stu[i].score[3];//0A,1C,2M,3E
  }
  for(course=0;course<4;course++){//判断哪个哪个就放外循环,这边不能写成int courese因为变量已定义,是同一变量
    sort(stu,stu+n,cmp);//分别排了4个成绩的序 应该得出四个结点,而不单单是分数
    Rank[stu[0].id][course]=1;//与库中元素重名
    for(int j=1;j<n;j++){
      if(stu[j].score[course]==stu[j-1].score[course]){
         Rank[stu[j].id][course]= Rank[stu[j-1].id][course];
      }
        
      else Rank[stu[j].id][course]=j+1;//=号右边原来是错误的
    }
  }

  for(int i=0;i<m;i++){
    scanf("%d",&q);
    if(Rank[q][0]==0) printf("N/A\n");
    else{
      int temp=0;
      for(int i=0;i<4;i++){
        if(Rank[q][i]<Rank[q][temp])
          temp=i;
        //选出被查询学生4科中排名最前的一科
      }
      printf("%d %c\n",Rank[q][temp],k[temp]);
    }
  }
  return 0;
} 

这里犯了数组名不能与库函数同名,已定义的同一变量不能再声明的错误。以及一开始没有意识到结构体排序是排得结点。还有bool函数的参数里应写结构体的本名,而不是引用名。

以及排序到了第3个人,他应该就是第3名,而不是前面并列的名次+1。

猜你喜欢

转载自blog.csdn.net/qq_24572475/article/details/82811274