浙大数据结构02-线性结构3 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

这道题我踩了一个坑就是反转的链表是每k个反转不是反转前k个英语菜鸡的锅。。┭┮﹏┭┮
解题思路:先将每个数字的地址转换为数字作为下标存储数据和下一个数字的地址,再重新定义一个数组将地址按照数字对应的顺序存储,再实现按照每k个反转一次,最后再按照对应地址输出,详见代码及注释

#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <cstdio>
using namespace std;
const int N = 1e3 + 5;
struct Node
{
    int add;//存储地址
    int data;//存储数据
    int next;//存储下一个数字的地址
}a[N];
int b[N];
int main()
{
    int address/*首数字地址*/,num,k;
    cin >> address >> num >> k;
    int tempadd;
    for(int i = 1 ;i <= num ; i++)
    {
        cin >> tempadd;//输入数字地址
        cin >> a[tempadd].data;//将数据存到其对应“地址”
        cin >> a[tempadd].next;//存入下一个数据地址
        a[tempadd].add = tempadd;//存入数据地址
    }
    int index = 1;//b数组的下标
    while(address != -1)
    {
        b[index++] = address;/*将每个数据的对应地址按照数据从小到大的顺序存储*/
        address = a[address].next;/*取下一个数据的地址*/
    }
    b[index] = -1;/*最后一个数据的下一个地址是-1*/
    for(int i = 1; i + k <= index; i += k)
    {
        reverse(b + i, b + i + k);//每k个反转
    }
    for(int i = 1; i < index; i++)
    {
        printf("%05d %d ",b[i],a[b[i]].data);/*按反转后的顺序输出*/
        if(b[i+1] != -1)
        {
            printf("%05d\n",b[i+1]);
        }
        else
        {
            cout <<"-1" <<endl;
        }
    }
    return 0;
}

发布了18 篇原创文章 · 获赞 4 · 访问量 320

猜你喜欢

转载自blog.csdn.net/leslie___/article/details/105573808