HUD-1003


title: HDU-1003
categories:

  • ACM
  • 动态规划
    tags:
  • 最大连续子序列
    date: 2020-02-07 16:06:14

这个问题作者都描述错了,应该是如果有多个结果,输出end最靠后,start最靠前的那个结果。这个和1002质量都不行,原来和1002是同一个作者

题目

Max Sum

*Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 344830 Accepted Submission(s): 82002
*

Problem Description

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

代码:

验证作者描述错误的序列:-100 5 5 -100 1 -1 10 -100

#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
	//freopen("input.txt", "r", stdin);
	int t;
	cin>>t;
	for(int i=1;i<=t;i++){
		int n,max,kaishi,jieshu,shuzi;
		max=0;
		int maxmax=-1;
		int maxkaishi,maxjieshu;
		cin>>n;
		kaishi=1;
		for(int j=1;j<=n;j++)
		{
			cin>>shuzi;
			if(max>=0){
				max+=shuzi;
				jieshu=j;
			}
			else
			{
				max=shuzi;
				kaishi=j;
				jieshu=j;
			}
			 
			if(max>=maxmax){
				maxmax=max;
				maxkaishi=kaishi;
				maxjieshu=jieshu;
			}
		}
		cout<<"Case "<<i<<":"<<endl<<maxmax<<" "<<maxkaishi<<" "<<maxjieshu<<endl;
		if(i!=t)cout<<endl;	
	}
} 
发布了25 篇原创文章 · 获赞 1 · 访问量 497

猜你喜欢

转载自blog.csdn.net/qq_43985303/article/details/104212307
HUD