树 并查集

Training 4 - D题

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

his problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

   The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 

Output

   For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.Sponsor

#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e6 + 5;

int fa[maxn];

void initial(int n)
{
	for (int i = 1; i <= n; i++)
	{
		fa[i] = i;
	}
}

int get(int x)
{
	if (x == fa[x])
		return x;
	return fa[x] = get(fa[x]);
}

void merge(int x, int y)
{
	fa[get(x)] = get(y);
}

int main()
{
	int cas = 0;
	int x, y;
	bool flag = 1;
	set<int> node;
	int edge = 0;
	initial(1e6);
	while (scanf("%d%d", &x, &y) != EOF)
	{
		if (x == -1 && y == -1)
			break;
		if (x == 0 && y == 0)
		{
			if (node.size() != 0 && node.size() != edge + 1)
				flag = 0;
			if (flag)
				printf("Case %d is a tree.\n", ++cas);
			else
				printf("Case %d is not a tree.\n", ++cas);
			initial(1e6);
			flag = 1;
			node.clear();
			edge = 0;
		}
		else
		{
			if (get(x) == get(y))
				flag = 0;
			merge(x, y);
			edge++;
			node.insert(x);
			node.insert(y);
		}
	}
	return 0;
}

思路:
判断是不是树的条件:①可以是空树;②不能有环;③结点数比边数多一(只有一个根节点)。

发布了28 篇原创文章 · 获赞 0 · 访问量 325

猜你喜欢

转载自blog.csdn.net/xukeke12138/article/details/104738416
今日推荐