树算法专题(三)并查集

问题:How Many Tables

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input:The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output:For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4
#include <cstdio>
#include <iostream>
#include <cstring>

using namespace std;
const int maxn = 1050;
int a[maxn];

int Find(int n);
void merge(int x,int y);

int main(){
    int t;
    cin>>t;
    while(t--){
        int n,m;
        cin>>n>>m;
        for(int i=1;i<maxn;i++){
            a[i] = i;
        }
        int x,y;
        for(int i=1;i<=m;i++){
            cin>>x>>y;
            merge(x,y);
        }
        int ans = 0;
        for(int i=1;i<=n;i++){
            if(a[i]==i){
                ans++;
            }
        }
        cout<<ans<<endl;
    }    
    return 0;
}

int Find(int x){
    if(a[x]==x){
        return x;
    }
    return a[x]=Find(a[x]);
}

void merge(int x,int y){
    int fx = Find(x);
    int fy = Find(y);
    if(fx!=fy){
        a[fx] = fy;
    }
}

猜你喜欢

转载自www.cnblogs.com/bijian/p/12357391.html
今日推荐