百练#1852Ants

描述
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
输入
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
输出
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
样例输入
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
样例输出
4 8
38 207

#include<iostream>
#define MAX 1000000
#define MIN 0
using namespace std;
int main(){
	int N,l,n,i,j,fmin,fmax;
	int ants[MAX];
	scanf("%d",&N);
	for(j = 0;j < N; ++j){
		scanf("%d%d",&l,&n);
		for(i = 0;i < n; ++i)
			scanf("%d",ants + i);
		fmin = MIN;
		fmax = MIN;
		for(i = 0;i < n; ++i){
			fmin = max(fmin,min(ants[i],l - ants[i]));
			fmax = max(fmax,max(ants[i],l - ants[i]));
		}
		printf("%d %d\n",fmin,fmax);
	}
	return 0;
}

蚂蚁碰面后往回走相当于对面的蚂蚁继续往前走,因此可以看做所有蚂蚁独立行走,因此最短时间就是所有蚂蚁最短时间的最大时间,最长时间就是所有蚂蚁最长时间的最长时间。
智商题?

发布了53 篇原创文章 · 获赞 0 · 访问量 726

猜你喜欢

转载自blog.csdn.net/weixin_38894974/article/details/104371542