poj1852Ants

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

题意概括:
有n只蚂蚁在木棍上爬行,每只蚂蚁的速度都是每秒1单位长度,现在给你所有蚂蚁初始的位置(蚂蚁运动方向未定),蚂蚁相遇会掉头反向运动,让你求出所有蚂蚁都·掉下木棍的最短时间和最长时间。
解题思路:
因为蚂蚁都是一样的,所以当两只蚂蚁相遇时转向跟没转向没什么区别,因为每只蚂蚁都会继承另一只蚂蚁的方向,所以·可以视为蚂蚁方向不变,所以最短时间就是所有蚂蚁距端点最近距离的最大值,最长时间就是所有蚂蚁距端点最远距离的最大值。

#include<iostream>
#include<cstdio>
using namespace std;
const int N = 1e5+10;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--) {
        int l,n,m;
        int ma = -N;
        int mi = -N;
        scanf("%d%d",&l,&n);
        for(int i = 0; i < n; i++) {
            int x,y,s;
            scanf("%d",&s);
            x = min(s,l-s);
            y = max(s,l-s);
            mi = max(mi,x);
            ma = max(ma,y);
        }
        printf("%d %d\n",mi,ma);
    } 
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/clb123/p/12328105.html
今日推荐