poj 1852 Ants

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

 
最短时间肯定是所有蚂蚁都往近的一方运动,此时不存在交错,那么最长时间呢,我们可以认为每只蚂蚁都是独立的,可以想象一下,任意两只蚂蚁如果彼此都朝着远的一端去行动,假设他们离最近的一端分别为a,b,总长度是l,如果不交错,有两种情况,l - a,l - b,如果交错就有 l - (a + b) / 2肯定不是 最长的时间,显然最大值在前面两种情况中,所以只要求出每个蚂蚁距离较远端的最大距离即可,经过碰撞可能会让要走的路变少。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
int t;
int m,n,s[1000000];
int min_,max_;
int main()
{
    int d;
    scanf("%d",&t);
    while(t --)
    {
        scanf("%d%d",&m,&n);
        max_ = min_ = 0;
        while(n --)
        {
            scanf("%d",&d);
            min_ = max(min_,min(d,m - d));
            max_ = max(max_,max(d,m - d));
        }
        printf("%d %d\n",min_,max_);
    }
}

猜你喜欢

转载自www.cnblogs.com/8023spz/p/8994858.html