POJ1852 Ants

题目链接: POJ1852 Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 34300 Accepted: 12693

Description
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

程序说明:

求最短时间是每只蚂蚁都朝向较近的端点。实际上两只蚂蚁相遇后可以认为保持原样交错而过继续前进,求最长时间即求出蚂蚁到端点的最大距离。
参考链接:POJ1852 UVa10714 ZOJ2376 Ants【水题】

代码如下:

#include <iostream>
using namespace std;
int main() {
	int t, n, l, left, right;
	cin>>t;
	while(t--) {
		cin>>l>>n;
		int max = 0, min = 0;
		for(int i = 0; i < n; i++) {
			cin>>left;
			right = l - left;
			if(left > right) {//始终保持到左端点的距离大于到右端点的距离
				swap(left, right);
			}
			if(right > max)
				max = right;
			if(left > min)
				min = left;
		}
		cout<<min<<" "<<max<<endl;
	}	
	return 0;
}
发布了44 篇原创文章 · 获赞 0 · 访问量 861

猜你喜欢

转载自blog.csdn.net/Komatsu_1137/article/details/103978706