PAT-1012 The Best Rank (25 分)成绩排序

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

思路

这个题一看这么多数据,可以构造一个结构体来存储,为了存储和计算的方便,我们可以把三科成绩总和当作平均值,这样就可以用int来存储了。

然后注意的是需要多次排序,所以定义一个全局变量,控制每次排序cmp方法中比较变量。

坑点:如果按照上边的步骤完整的走,可能会出现第三个点过不去,我就遇到了这个情况,在写排序的时候,我还在想如果两个同学的成绩一样的话,那么排名如何计算???可能是我英文不是太好,没有仔细看清题意。 

!!!!一定要注意 :当两名同学的成绩都为最高分时,他俩并列第一,接下来的同学排名为第三。

代码

#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

struct node{
	char name[6];
	int score[4];
	int rank[4];
};
typedef node nn;
nn s[2000];
int p;
const char ss[4] = {'A', 'C', 'M', 'E'}; 

bool cmp(nn n1, nn n2){
	if (n1.score[p] > n2.score[p]) return true;
	else return false;
}

int main(){
	int n,m;
	scanf("%d%d", &n, &m);
	for (int i = 0; i < n; i++) {
		scanf("%s %d %d %d", s[i].name, &s[i].score[1], &s[i].score[2], &s[i].score[3]);
		s[i].score[0] = s[i].score[1] + s[i].score[2] + s[i].score[3];
	}
	
	for(p = 0; p <= 3; p++){
		sort(s, s+n, cmp);
		s[0].rank[p] = 1;
		for (int i = 1; i < n; i++) {
			if (s[i].score[p] == s[i-1].score[p])
				s[i].rank[p] = s[i-1].rank[p];
			else s[i].rank[p] = i+1;
		}
	}
	/*for(int i = 0; i < n; i++){
		printf("%s %d %d %d %d\n",s[i].name, s[i].score[0], s[i].score[1], s[i].score[2], s[i].score[3]);
	}*/
	char id[8];
	while (m--) {
		scanf("%s", id);
		bool flag = false;
		for (int i = 0; i < n; i++) {
			if (strcmp(id, s[i].name) == 0) {
				int maxn = 9999, pointer = 0;
				for (int j = 0; j <= 3; j++) {
					if (s[i].rank[j] < maxn) {
						maxn = s[i].rank[j];
						pointer = j;
					}
				}
				printf("%d %c\n", maxn,ss[pointer]);
				flag = true;
				continue;
			}
		}
		if (flag) continue;
		printf("N/A\n");
	}
	return 0;
}
发布了148 篇原创文章 · 获赞 52 · 访问量 24万+

猜你喜欢

转载自blog.csdn.net/m0_38072683/article/details/94591275