pat-1012 The Best Rank(25)(多条件排序)

1012 The Best Rank(25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

作者: CHEN, Yue

单位: 浙江大学

时间限制: 200 ms

内存限制: 64 MB

代码长度限制: 16 KB

 大小姐好强!!学习博客链接!

我学习的前路依旧漫漫呀!

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <set>
using namespace std;
typedef struct{
    int id,best;
    int score[4];//A - 0、C - 1、M - 2、E - 3;
    int rank[4];
} Student;
Student a[2005];
int now;
bool cmp(Student x,Student y)
{
    return x.score[now] > y.score[now];
}
int exist[1000000];

int main()
{
    int n,m;
    cin>>n>>m;
    for(int  i = 0 ; i < n ;i++)
    {
        cin>>a[i].id>>a[i].score[1]>>a[i].score[2]>>a[i].score[3];
        a[i].score[0] = (a[i].score[1] + a[i].score[2] + a[i].score[3]) / 3.0 + 0.5;
    }
    for(now = 0;now < 4;now++)
    {
        sort(a,a + n,cmp);
        a[0].rank[now] = 1;
        for(int j = 1; j < n;j ++)
        {
            a[j].rank[now] = j + 1;
            if(a[j].score[now] == a[j - 1].score[now])
                a[j].rank[now] = a[j - 1].rank[now];
        }
    }
    for(int i = 0 ;i < n ;i ++)
    {
        exist[a[i].id] = i + 1;
        a[i].best = 0;
        int minn = a[i].rank[0];
        for(int j = 1;j < 4;j++)
        {
            if(a[i].rank[j] < minn)
            {
                minn = a[i].rank[j];
                a[i].best = j;//最好排名
            }
        }
    }
    char c[5] = {'A','C','M','E'};
    int f;
    for(int i = 0 ; i < m;i++)
    {
        cin>>f;
        int tmp = exist[f];
        if(tmp)
        {
            int z = a[tmp - 1].best;
            printf("%d %c\n",a[tmp- 1].rank[z],c[z]);
        }
        else
            printf("N/A\n");
    }
    
    
    return 0;
}


猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/82255158