5.5 质因子分解:A1059 Prime Factors

A1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​^k​1​​​​×p​2^​​​k​2​​​​×⋯×p​m^​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

#include <cstdio>
#include <stdlib.h>
#include <cstring>
#include <iostream>
#include <math.h>
using namespace std;
const int maxn=10010;
int prime[maxn],pnum=0;
bool isprime(int n){
    if(n==1) return false;
    int sqr=(int)sqrt(1.0*n);
    for(int i=2;i<=sqr;i++){
        if(n%i==0) return false;
    }
    return true;
}
void Find_Prime(){
    for(int i=1;i<maxn;i++){
        if(isprime(i))
            prime[pnum++]=i;
    }
}
struct factor{
    int x,cnt;//x为质因子,cnt为其个数
}fac[10];
int main(){
    Find_Prime();
    int n,num=0;
    scanf("%d",&n);
    int sqr=(int)sqrt(1.0*n);
    if(n==1) printf("1=1");
    else{
        printf("%d=",n);
        for(int i=0;i<pnum&&prime[i]<=sqr;i++){
            if(n%prime[i]==0){
                fac[num].x=prime[i];
                fac[num].cnt=0;
                while(n%prime[i]==0){
                    fac[num].cnt++;
                    n/=prime[i];
                }
                num++;
            }
            if(n==1) break;
        }
        if(n!=1){//如果无法被根号n以内的质因子除尽,那么一定有一个大于根号n的质因子
            fac[num].x=n;
            fac[num++].cnt=1;
        }
        for(int i=0;i<num;i++){
            if(i>0) printf("*");
            printf("%d",fac[i].x);
            if(fac[i].cnt>1)
                printf("^%d",fac[i].cnt);
        }
    }
    return 0;
}
发布了157 篇原创文章 · 获赞 15 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/nanke_4869/article/details/104678070