1059 Prime Factors (25)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p~1~\^k~1~ * p~2~\^k~2~ *…*p~m~\^k~m~.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p~1~\^k~1~ * p~2~\^k~2~ *…*p~m~\^k~m~, where p~i~'s are prime factors of N in increasing order, and the exponent k~i~ is the number of p~i~ -- hence when there is only one p~i~, k~i~ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include<stdio.h>
#include<cmath>
const int maxn = 100010;
int Prime[maxn], pNum = 0;
bool p[maxn] = { 0 };

void Find_Prime() {     //如果传入参数n会造成地址冲突
    for (int i = 2; i < maxn; i++) {
        if (p[i] == false) {
            Prime[pNum++] = i;
            for (int j = i + i; j < maxn; j += i) {
                p[j] = true;
            }
        }
    }
}

struct factor {
    int x, cnt;
}fac[10];


int main() {
    int n, num = 0, sqr;
    scanf("%d", &n);
    Find_Prime();
    sqr = (int)sqrt(1.0 * n);
    printf("%d=", n);
    if (n == 1) printf("1");//注意对于1的特判
    else {
        for (int i = 0; i < pNum && Prime[i] <= sqr; i++) {  // 不可直接在循环条件中使用sqrt(n) //且注意sqr前需要取“=”
            if (n % Prime[i] == 0) {
                fac[num].x = Prime[i];
                fac[num].cnt = 0;
                while (n % Prime[i] == 0) {
                    fac[num].cnt++;
                    n /= Prime[i];
                }
                num++;
            }
            if (n == 1) break; //及时退出循环
        }
        if (n != 1) {
            fac[num].x = n;
            fac[num++].cnt = 1;
        }
        for (int i = 0; i < num; i++) {
            if (fac[i].cnt > 1) printf("%d^%d", fac[i].x, fac[i].cnt);
            else printf("%d", fac[i].x);
            if (i != num - 1) printf("*");
        }
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/Yaxadu/p/9173502.html